ManaManaMall Apps
Your Smart Online Store - Mobiles, Tablets, Home Appliances, TV, Audio & More
  • Easy & Secure with ManaManaMall Apps
  • Get news & updates directly from your Smartphone
  • Support for iOS & Android
Requirements:
Compatible with All iPhone. Requires iPhone OS 2.2 or later. WiFi, Edge, or 3G/4G network connection sometimes required.
Requirements:
Requires Android 2.3 and higher. WiFi, Edge, or 3G/4G network connection sometimes required.